App Development with CakePHP 3.4 and Bootstrap 4.0

Next: Making a Bootstrap 4 Template for Cakephp UP: TOC

In the future we would like to use google, Facebook authentication and many more.

composer require ADmad/CakePHP-HybridAuth Using version ^4.0 for ADmad/CakePHP-HybridAuth ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) - Installing facebook/graph-sdk (5.4.4) Loading from cache - Installing hybridauth/hybridauth (v2.8.2) Loading from cache - Installing admad/cakephp-hybridauth (4.0.5) Loading from cache facebook/graph-sdk suggests installing paragonie/random_compat (Provides a better CSPRNG option in PHP 5) facebook/graph-sdk suggests installing guzzlehttp/guzzle (Allows for implementation of the Guzzle HTTP client) Writing lock file Generating autoload files > Cake\Composer\Installer\PluginInstaller::postAutoloadDump # composer require cakephp/authentication:1.0.0-beta2 ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) - Installing cakephp/authentication (1.0.0-beta2) Downloading: 100% cakephp/authentication suggests installing firebase/php-jwt (If you want to use the JWT adapter add this dependency) Writing lock file Generating autoload files > Cake\Composer\Installer\PluginInstaller::postAutoloadDump Next: Making a Bootstrap 4 Template for Cakephp UP: TOC